CISCO CCNA OSPF

Posted filed under Cisco CCNA.


 
seated at PC1 =10.10.10.1 I can not ping 30.30.30.6

 

WHY? Since when I go to R1#show ip route I do not see the network
30.30.30.0

 

R1#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

 

Gateway of last resort is not set

 

1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, FastEthernet0/0
20.0.0.0/30 is subnetted, 1 subnets
C 20.20.20.4 is directly connected, Serial0/0

 

As we see R1 does not see the network 30.30.30.0

So I will go advertise it via OSPF

 

Receive our Cisco CCNA Packet Tracer!
Get our complete tutorial in PDF
 
 

 

hint : make sure you type Show ip int brief before you advertise it

 

—————–here I go to R1—-

 

 hint:make sure you adverstsie it with correct WILD cards

 

 

/30 wild cards is 0.0.0.3
/24 wild cards is 0.0.0.255

 

 hint : when you do OSPF advertisment ; you must use correct subnet ID

 

that is for R1 f0/0 subnet ID= 10.10.10.0
R1 s0/0 subnet ID = 20.20.20.4
—————–here is my R1 configuration
R1#config t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router ospf 110
R1(config-router)#network 20.20.20.4 0.0.0.3 area 0
R1(config-router)#network 10.10.10.0 0.0.0.255 area 0
R1(config-router)#network 1.1.1.0 0.0.0.255 area 0
R1(config-router)#
————-here is my show run on R1———-
R1#show run

router ospf 110
log-adjacency-changes
network 20.20.20.4 0.0.0.3 area 0
network 10.10.10.0 0.0.0.255 area 0
network 1.1.1.0 0.0.0.255 area 0
——————-now I will go to R2#———-

 

 hint : make sure you type SHOW ip int brief ; so you can see what u have

 

R2#show ip int brief
Interface                 IP-Address      OK?     Method      Status                          Protocol

FastEthernet0/0     30.30.30.100    YES     manual        up                                   up
FastEthernet0/1      unassigned     YES       unset         administratively down       down
Serial0/0                 20.20.20.6      YES     manual        up                                   up
Loopback0              2.2.2.2           YES      manual       up                                   up

R2#config t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router os
R2(config)#router ospf 110
R2(config-router)#network 30.30.30.0 0.0.0.255 area 0
R2(config-router)#network 2.2.2.0 0.0.0.255 area 0
R2(config-router)#network 20.20.20.4 0.0.0.3 area 0
R2(config-router)#
00:22:11: %OSPF-5-ADJCHG: Process 110, Nbr 1.1.1.1 on Serial0/0 from LOADING to FULL, Loading Done

 

——————-as we see as soon as I advertised the S0/0 I see some action—————-
lets look at show run on R2#
router ospf 110
log-adjacency-changes
network 30.30.30.0 0.0.0.255 area 0
network 2.2.2.0 0.0.0.255 area 0
network 20.20.20.4 0.0.0.3 area 0

 

—————————now lets look at show ip ospf neighbors

 

R2#show ip ospf neighbor

Neighbor ID       Pri State     Dead Time       Address        Interface
1.1.1.1 0           FULL/ –      00:00:32           20.20.20.5      Serial0/0
R2#

 

———————-as we see remember ONLY we have DR/BDR on LAN segments 

 

lets look at another show command :
R2#show ip ospf int
FastEthernet0/0 is up, line protocol is up
Internet address is 30.30.30.100/24, Area 0
Process ID 110, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 2.2.2.2, Interface address 30.30.30.100
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:05
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
Loopback0 is up, line protocol is up
Internet address is 2.2.2.2/24, Area 0
Process ID 110, Router ID 2.2.2.2, Network Type LOOPBACK, Cost: 1
Loopback interface is treated as a stub Host
Serial0/0 is up, line protocol is up
Internet address is 20.20.20.6/30, Area 0
Process ID 110, Router ID 2.2.2.2, Network Type POINT-TO-POINT, Cost: 781
Transmit Delay is 1 sec, State POINT-TO-POINT, Priority 0
No designated router on this network
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:03
Index 3/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1 , Adjacent neighbor count is 1
Adjacent with neighbor 1.1.1.1
Suppress hello for 0 neighbor(s)

 

——————-as we see when I type show ip ospf Int ; it will give me all interface

 

As I see Int f0/0 – called broadcast ( i can see DR)
int s0/0 -called Point-to-point ( no mention of DR/BDR)

 

————————-lets look at R2#show ip route

 

R2#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/782] via 20.20.20.5, 00:05:12, Serial0/0
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
O 10.10.10.0 [110/782] via 20.20.20.5, 00:05:12, Serial0/0
20.0.0.0/30 is subnetted, 1 subnets
C 20.20.20.4 is directly connected, Serial0/0
30.0.0.0/24 is subnetted, 1 subnets
C 30.30.30.0 is directly connected, FastEthernet0/0

 

——————now I should be able to ping from PC1 to PC6

 

Watch the video and you will be able to understand OSPF and Wild Card Part 2 much better and Please subscribe to our YouTube Channel.

50-discount-on-self-study-online-class
 

Want more information on how to become Cisco CCNA Certified? Learn more!
Join our Cisco CCNA facebook study group!
 


Also published on Medium.

One Response to “Cisco CCNA OSPF and Wild Card Part 2”