Cisco CCNA IPV6 Static Configuration

Now I will do small Lab: The Goal is that seated at R4 be able to ping all the loopback of R10 , in order to do this , we will cover Static Route.

 

R4=10.10.10.4

R10=10.10.10.10 connected via LAN link

 

Also I will have IPV6 as follow:

r4 f0/0=2001:4444::4/64

r10 f0/0=2001:4444::10/64

In here we have R4 and R10  with the following:

Here is:

R4#Show run

interface FastEthernet0/0

ip address 10.10.10.4 255.255.255.0

duplex auto

speed auto

ipv6 address 2001:4444::4/64

 

Here is R10  with so many loopback address:

interface Loopback0

ip address 100.100.100.100 255.255.255.0

!

interface Loopback1

no ip address

ipv6 address FEC0:1000::1/128

!

interface Loopback2

no ip address

ipv6 address FEC0:1000::2/128

!

interface Loopback3

no ip address

ipv6 address FEC0:1000::3/128

!

interface Loopback4

no ip address

ipv6 address FEC0:1000::4/128

!

interface FastEthernet0/0

ip address 10.10.10.10 255.255.255.0

duplex auto

speed auto

ipv6 address 2001:4444::10/64

 

Right now when i go to R4#show ipv6 route i do not see the loopback from R10 why?

Since i need to run do ipv6 Static Route

R4#show ipv6 route

IPv6 Routing Table – 3 entries

Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP

U – Per-user Static route, M – MIPv6

I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary

O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2

ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2

D – EIGRP, EX – EIGRP external

C   2001:4444::/64 [0/0]

via ::, FastEthernet0/0

L   2001:4444::4/128 [0/0]

via ::, FastEthernet0/0

L   FF00::/8 [0/0]

via ::, Null0

 

 

So remember you need enable unicast-routing

 

Hint: on global Configuration start with IPV6?

Here is my configuration on R4#

 

Step 1) Enable Unicast-routing on R4

 

Receive our Cisco CCNA Packet Tracer!
Get our complete tutorial in PDF

R4#config t

Enter configuration commands, one per line.  End with CNTL/Z.

R4(config)#ipv

R4(config)#ipv6 ?

access-list      Configure access lists

cef              Cisco Express Forwarding

dhcp             Configure Ipv6 DHCP

general-prefix   Configure a general IPv6 prefix

host             Configure static hostnames

inspect          Context-based Access Control Engine

local            Specify local options

nat              NAT-PT Configuration commands

neighbor         Neighbor

route            Configure static routes

router           Enable an IPV6 routing process

unicast-routing  Enable unicast routing

R4(config)#ipv6 unicast-routing

 

Step 2) Now I will configure Static Route, in here I need to put the destination Network  inside my R4 router

 

That is I need to have:

 ipv6 route     FEC0:1000::1/128                    2001:4444::10

                    Destination Network                   (Next Hop address)

 

We must do above commands for all Loopback address , since the goal is that seated at R4

I should be able to ping all loopback address located on R10

 

ipv6 route FEC0:1000::2/128 2001:4444::10

ipv6 route FEC0:1000::3/128 2001:4444::10

ipv6 route FEC0:1000::4/128 2001:4444::10

 

 

Now we will configure it on R4 (using the ? mark)

R4#config t

Enter configuration commands, one per line.  End with CNTL/Z.

R4(config)#ipv6 ?

access-list      Configure access lists

cef              Cisco Express Forwarding

dhcp             Configure Ipv6 DHCP

general-prefix   Configure a general IPv6 prefix

host             Configure static hostnames

inspect          Context-based Access Control Engine

local            Specify local options

nat              NAT-PT Configuration commands

neighbor         Neighbor

route            Configure static routes

router           Enable an IPV6 routing process

unicast-routing  Enable unicast routing

R4(config)#ipv6 route ?

X:X:X:X::X/<0-128>  IPv6 prefix

R4(config)#ipv6 route FEC0:1000::1/128 ?

Ethernet         IEEE 802.3

FastEthernet     FastEthernet IEEE 802.3

GigabitEthernet  GigabitEthernet IEEE 802.3z

Loopback         Loopback interface

Serial           Serial

Vlan             Catalyst Vlans

X:X:X:X::X       IPv6 address of next-hop

R4(config)#ipv6 route FEC0:1000::1/128 2001:4444::10 ?

<1-254>  Administrative distance

<cr>

R4(config)#ipv6 route FEC0:1000::1/128 2001:4444::10

R4(config)#

 

Now I will just use up arrow key and put the rest of loopback network

 

R4(config)#ipv6 route FEC0:1000::1/128 2001:4444::10

R4(config)#

R4(config)#

R4(config)#ipv6 route FEC0:1000::2/128 2001:4444::10

R4(config)#ipv6 route FEC0:1000::3/128 2001:4444::10

R4(config)#ipv6 route FEC0:1000::4/128 2001:4444::10

 

Here is my show run so far on R4#

R4#show run

ipv6 unicast-routing

!

!

!

ipv6 route FEC0:1000::1/128 2001:4444::10

ipv6 route FEC0:1000::2/128 2001:4444::10

ipv6 route FEC0:1000::3/128 2001:4444::10

ipv6 route FEC0:1000::4/128 2001:4444::10

!

 

Now If I try to ping from R4 to the loopback address of R10 , it will work .

R4#ping FEC0:1000::1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to FEC0:1000::1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms

 

R4#ping FEC0:1000::2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to FEC0:1000::2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

R4#ping FEC0:1000::3

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to FEC0:1000::3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms

 

R4#ping FEC0:1000::4

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to FEC0:1000::4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/8 ms

But if I had some loopback address on the R4 , then R10 can not ping that loopback address , we can use same concept as above or I Can show you the concept of Default route.

I go to R4 and create one Loopback address on R4#

R4#config t

Enter configuration commands, one per line. End with CNTL/Z.

R4(config)#int loopback 1

R4(config-if)#ipv6 address FEC0:4000::1/128

R4(config-if)#

R4(config-if)#int loopback 2

R4(config-if)#ipv6 address FEC0:4000::2/128

 

R10#

Step 3) Hint: remember to enable IPV6 unicast-routing on R10

 

R10#config t

Enter configuration commands, one per line.  End with CNTL/Z.

R10(config)#ipv

R10(config)#ipv6 un

R10(config)#ipv6 ?

access-list      Configure access lists

cef              Cisco Express Forwarding

dhcp             Configure Ipv6 DHCP

general-prefix   Configure a general IPv6 prefix

host             Configure static hostnames

inspect          Context-based Access Control Engine

local            Specify local options

nat              NAT-PT Configuration commands

neighbor         Neighbor

route            Configure static routes

router           Enable an IPV6 routing process

unicast-routing  Enable unicast routing

R10(config)#ipv6 uni

R10(config)#ipv6 unicast-routing

R10(config)#

 

Step 4) Now I will do Default route on R10 and I will use next hop address

 

R10#

ipv6 route ::/0 2001:4444::4

 

Hint: for default route in Ipv4 we use 0.0.0.0    0.0.0.0 but for Ipv6 we will use ::/0

R10#config t

Enter configuration commands, one per line.  End with CNTL/Z.

R10(config)#ipv

R10(config)#ipv6 ?

access-list      Configure access lists

cef              Cisco Express Forwarding

dhcp             Configure Ipv6 DHCP

general-prefix   Configure a general IPv6 prefix

host             Configure static hostnames

inspect          Context-based Access Control Engine

local            Specify local options

nat              NAT-PT Configuration commands

neighbor         Neighbor

route            Configure static routes

router           Enable an IPV6 routing process

unicast-routing  Enable unicast routing

R10(config)#ipv6 rout

R10(config)#ipv6 route ?

X:X:X:X::X/<0-128>  IPv6 prefix

R10(config)#ipv6 route ::/0 ?

Ethernet         IEEE 802.3

FastEthernet     FastEthernet IEEE 802.3

GigabitEthernet  GigabitEthernet IEEE 802.3z

Loopback         Loopback interface

Serial           Serial

Vlan             Catalyst Vlans

X:X:X:X::X       IPv6 address of next-hop
R10(config)#ipv6 route ::/0 2001:4444::4

R10(config)#

 Here is my Show run on R10#

 ipv6 unicast-routing

ipv6 route ::/0 2001:4444::4

Now seated on R10 I should be able to ping the Loopback address of R4

 R10#ping FEC0:4000::1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to FEC0:4000::1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

 

R10#ping FEC0:4000::2

 Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to FEC0:4000::2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms

 R10#

 Here is show Ipv6 route on R4 and R10

 R4#show ipv6 route

IPv6 Routing Table – 9 entries

Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP

U – Per-user Static route, M – MIPv6

I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary

O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2

ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2

D – EIGRP, EX – EIGRP external

C   2001:4444::/64 [0/0]

via ::, FastEthernet0/0

L   2001:4444::4/128 [0/0]

via ::, FastEthernet0/0

S   FEC0:1000::1/128 [1/0]

     via 2001:4444::10

S   FEC0:1000::2/128 [1/0]

     via 2001:4444::10

S   FEC0:1000::3/128 [1/0]

     via 2001:4444::10

S   FEC0:1000::4/128 [1/0]

     via 2001:4444::10

C   FEC0:4000::1/128 [0/0]

via ::, Loopback1

C   FEC0:4000::2/128 [0/0]

via ::, Loopback2

L   FF00::/8 [0/0]

via ::, Null0

 

Here is show ipv6 route for R10

R10#show ipv6 route

IPv6 Routing Table – 8 entries

Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP

U – Per-user Static route, M – MIPv6

I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary

O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2

ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2

D – EIGRP, EX – EIGRP external

S   ::/0 [1/0]

     via 2001:4444::4

C   2001:4444::/64 [0/0]

via ::, FastEthernet0/0

L   2001:4444::10/128 [0/0]

via ::, FastEthernet0/0

C   FEC0:1000::1/128 [0/0]

via ::, Loopback1

C   FEC0:1000::2/128 [0/0]

via ::, Loopback2

C   FEC0:1000::3/128 [0/0]

via ::, Loopback3

C   FEC0:1000::4/128 [0/0]

via ::, Loopback4

L   FF00::/8 [0/0]

via ::, Null0

 

Here is summary on R4 and R10 show run:

R4#show run

interface Loopback0

ip address 4.4.4.4 255.255.255.0

!

interface Loopback1

no ip address

ipv6 address FEC0:4000::1/128

!

interface Loopback2

no ip address

ipv6 address FEC0:4000::2/128

!

interface FastEthernet0/0

ip address 10.10.10.4 255.255.255.0

duplex auto

speed auto

ipv6 address 2001:4444::4/64

!

 

ipv6 route FEC0:1000::1/128 2001:4444::10

ipv6 route FEC0:1000::2/128 2001:4444::10

ipv6 route FEC0:1000::3/128 2001:4444::10

ipv6 route FEC0:1000::4/128 2001:4444::10

 

R10#show run

Building configuration…

 

ipv6 unicast-routing

!

 

interface Loopback1

no ip address

ipv6 address FEC0:1000::1/128

!

interface Loopback2

no ip address

ipv6 address FEC0:1000::2/128

!

interface Loopback3

no ip address

ipv6 address FEC0:1000::3/128

!

interface Loopback4

no ip address

ipv6 address FEC0:1000::4/128

!

interface FastEthernet0/0

ip address 10.10.10.10 255.255.255.0

duplex auto

speed auto

ipv6 address 2001:4444::10/64

!

!

ipv6 route ::/0 2001:4444::4

!

 

[bs_icon name=”glyphicon glyphicon-expand”] Watch the video and you will be able to understand IPV6 Static Configuration much better and Please subscribe to our YouTube Channel.

50-discount-on-self-study-online-class

Want more information on how to become Cisco CCNA Certified? Learn more!
Join our Cisco CCNA facebook study group!

Exit mobile version