Cisco CCNA PPP Multilink Configuration
The Goal is that create a PPP Multilink on R1 and R2 so that the link between them will be double speed with IP address as follow:
R1:10.10.10.1 /30
R2: 10.10.10.2 /30Step 1) go to each router and give the PPP encapsulationR1#show ip int brief
Interface | IP-Address | OK? | Method | Status | Protocol |
FastEthernet0/0 | unassigned | YES | Method | administratively down | down |
Serial1/0 | unassigned | YES | manual | up | up |
Serial1/1 | unassigned | YES | Method | up | up |
Serial1/2 | unassigned | YES | Method | administratively down | down |
Serial1/3 | unassigned | YES | Method | administratively down | down |
Loopback1 | 1.1.1.1 | YES | manual | up | up |
R1#config t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int s1/0
R1(config-if)#encapsulation ?
atm-dxi ATM-DXI encapsulation
bstun Block Serial tunneling (BSTUN)
frame-relay Frame Relay networks
hdlc Serial HDLC synchronous
lapb LAPB (X.25 Level 2)
ppp Point-to-Point protocol
sdlc SDLC
sdlc-primary SDLC (primary)
sdlc-secondary SDLC (secondary)
smds Switched Megabit Data Service (SMDS)
stun Serial tunneling (STUN)
x25 X.25
R1(config-if)#encapsulation ppp
R1(config-if)#
*Sep 13 16:48:25.875: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down
R1(config-if)#int s1/1
R1(config-if)#encapsulation ppp
R1(config-if)#
*Sep 13 16:48:52.335: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to down
R1(config-if)#
R2(config-if)#encapsulation ppp
R2(config-if)#
R2(config-if)#
R2(config-if)#int s1/1
R2(config-if)#
R2(config-if)#
*Sep 13 16:51:07.551: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
R2(config-if)#encapsulation ppp
R2(config-if)#
R2(config-if)#
*Sep 13 16:51:14.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to up
R2(config-if)#
Now If I go to each router I will see up and up:
R1#show ip int brief
Interface | IP-Address | OK? | Method | Status | Protocol |
FastEthernet0/0 | unassigned | YES | NVRAM | administratively down | down |
Serial1/0 | unassigned | YES | manual | up | up |
Serial1/1 | unassigned | YES | NVRAM | up | up |
Serial1/2 | unassigned | YES | NVRAM | administratively down | down |
Serial1/3 | unassigned | YES | NVRAM | administratively down | down |
Loopback1 | 1.1.1.1 | YES | manual | up | up |
Step 2) Now I will go create a Multilink Interface under R1
R1#
int Multilink 100
ip address 10.10.10.1 255.255.255.252
ppp multilink
ppp multilink group 100
R1#config t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int mul
R1(config)#int multilink ?
<1-2147483647> Multilink interface number
R1(config)#int multilink 100
R1(config-if)#ip add
*Sep 13 16:58:20.103: %LINEPROTO-5-UPDOWN: Line protocol on Interface Multilink100, changed state to down
R1(config-if)#ip add
R1(config-if)#ip address 10.10.10.1 255.255.255.252
R1(config-if)#pppp multi
R1(config-if)#ppp multi
R1(config-if)#ppp multilink
R1(config-if)#ppp mul
R1(config-if)#ppp multilink ?
endpoint Configure the local Endpoint Discriminator
fragment Specify fragmentation parameters
group Put interface in a multilink bundle
idle-link Do not transmit fragments over the lowest speed link
interleave Allow interleaving of small packets with fragments
links Specify the limits on the number of links in a bundle
load-threshold Specify threshold used to add/delete links
mrru Configure multilink MRRU values
multiclass Configure support for Multiclass Multilink
queue Specify link queuing parameters
slippage Set constraints on amount of data the MLP reassembly engine
will buffer per link
<cr>
R1(config-if)#ppp multilink gro
R1(config-if)#ppp multilink group ?
<1-2147483647> Multilink group number
R1(config-if)#ppp multilink group 1
% Cannot add multilink-group interface to a different multilink group
R1(config-if)#ppp multilink group 100
As you see the group number and interface must be same on R1 , but for R2 I can use different Group number as we will see ( I will use group 200 for R2)
Here is show run so far on R1:
R1#show run
interface Multilink100
ip address 10.10.10.1 255.255.255.252
ppp multilink
ppp multilink group 100
!
Step 3) Now make sure go under each interface of int s1/0 and s1/1 give these commands and make sure use same as group 100
int s1/0
encapsultion ppp
ppp multilink
ppp multilink group 100
int s1/1
encapsultion ppp
ppp multilink
ppp multilink group 100
R1#config t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int s1/0
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 100
R1(config-if)#
R1(config-if)#int s1/1
R1(config-if)#ppp multilink
R1(config-if)#ppp multilink group 100
Now lets look at R1#show ip int brief
R1#show ip int brief
Interface | IP-Address | OK? | Method | Status | Protocol |
FastEthernet0/0 | unassigned | YES | NVRAM | administratively down | down |
Serial1/0 | unassigned | YES | manual | up | up |
Serial1/1 | unassigned | YES | NVRAM | up | up |
Serial1/2 | unassigned | YES | NVRAM | administratively down | down |
Serial1/3 | unassigned | YES | NVRAM | administratively down | down |
Multilink100 | 10.10.10.1 | YES | manual | down | down |
Loopback1 | 1.1.1.1 | YES | manual | up | up |
#
R1#
Interface | IP-Address | OK? | Method | Status | Protocol |
FastEthernet0/0 | unassigned | YES | Method | administratively down | down |
Serial1/0 | unassigned | YES | manual | up | up |
Serial1/1 | unassigned | YES | Method | up | up |
Serial1/2 | unassigned | YES | Method | administratively down | down |
Serial1/3 | unassigned | YES | Method | administratively down | down |
Loopback1 | 1.1.1.1 | YES | manual | up | up |
As we see I have Multilink 100 is Down Down ; since I need to do same concept on other side R2
Step 4) Now I will go create a Multilink Interface under R2
R2#
int Multilink 200
ip address 10.10.10.2 255.255.255.252
ppp multilink
ppp multilink group 200
R2#config t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#int multilink 200
R2(config-if)#ip address 10.10.10.2 255.255.255.252
R2(config-if)#ppp mult
R2(config-if)#ppp multilink
R2(config-if)#ppp mul
R2(config-if)#ppp multilink ?
endpoint Configure the local Endpoint Discriminator
fragment Specify fragmentation parameters
group Put interface in a multilink bundle
idle-link Do not transmit fragments over the lowest speed link
interleave Allow interleaving of small packets with fragments
links Specify the limits on the number of links in a bundle
load-threshold Specify threshold used to add/delete links
mrru Configure multilink MRRU values
multiclass Configure support for Multiclass Multilink
queue Specify link queuing parameters
slippage Set constraints on amount of data the MLP reassembly engine
will buffer per link
<cr>
R2(config-if)#ppp multilink gr
R2(config-if)#ppp multilink group 200
Step 5) Now make sure go under each interface of int s1/0 and s1/1 give these commands and make sure use same as group 200
R2#
int s1/0
encapsultion ppp
ppp multilink
ppp multilink group 200
int s1/1
encapsultion ppp
ppp multilink
ppp multilink group 200
R2(config)#int s1/0
R2(config-if)#ppp multilink
R2(config-if)#ppp multilink group 200
R2(config-if)#int s1/1
R2(config-if)#ppp multilink
R2(config-if)#ppp multilink group 200
R2(config-if)#
R2(config-if)#
Here is show run on R2 so far:
!
interface Multilink200
ip address 10.10.10.2 255.255.255.252
ppp multilink
ppp multilink group 200
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
no ip address
encapsulation ppp
serial restart-delay 0
ppp multilink
ppp multilink group 200
!
interface Serial1/1
no ip address
encapsulation ppp
serial restart-delay 0
ppp multilink
ppp multilink group 200
Now lets check show ip int brief on R2 and see if I can ping R1=10.10.10.1
R2#show ip int brief
Any interface listed with OK? value “NO” does not have a valid configuration
Interface | IP-Address | OK? | Method | Status | Protocol |
FastEthernet0/0 | unassigned | YES | unset | administratively down | down |
Serial1/0 | unassigned | YES | manual | up | up |
Serial1/1 | unassigned | YES | unset | up | up |
Serial1/2 | unassigned | YES | unset | administratively down | down |
Serial1/3 | unassigned | YES | unset | administratively down | down |
Virtual-Access1 | unassigned | NO | TFTP | down | down |
Multilink200 | 10.10.10.2 | YES | manual | up | up |
Loopback1 | 2.2.2.2 | YES | manual | up | up |
R2#
R2#ping 10.10.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/56/68 ms
Here are show good show commands:
R1#show ppp multilink
Multilink100, bundle name is R2
Endpoint discriminator is R2
Bundle up for 00:13:13, total bandwidth 3088, load 1/255
Receive buffer limit 24000 bytes, frag timeout 1000 ms
0/0 fragments/bytes in reassembly list
0 lost fragments, 0 reordered
0/0 discarded fragments/bytes, 0 lost received
0x38 received sequence, 0x38 sent sequence
Member links: 2 active, 0 inactive (max not set, min not set)
Se1/0, since 00:24:14
Se1/1, since 00:12:46
No inactive multilink interfaces
Here is show command on R2#:
R2#show ppp multilink
Multilink200, bundle name is R1
Endpoint discriminator is R1
Bundle up for 00:15:42, total bandwidth 3088, load 1/255
Receive buffer limit 24000 bytes, frag timeout 1000 ms
0/0 fragments/bytes in reassembly list
0 lost fragments, 1 reordered
0/0 discarded fragments/bytes, 0 lost received
0x3C received sequence, 0x3C sent sequence
Member links: 2 active, 0 inactive (max not set, min not set)
Se1/0, since 00:15:42
Se1/1, since 00:15:16
No inactive multilink interfaces
Here is show int S1/0 before the Multi-link as we see it will be double in Multilink:
R1#show int s1/0
Serial1/0 is up, line protocol is up
Hardware is M4T
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Open, multilink Open
Link is a member of Multilink bundle Multilink100, crc 16, loopback not set
Keepalive set (10 sec)
Restart-Delay is 0 secs
Last input 00:00:56, output 00:00:04, output hang never
Now If I Go to R1 and ping R2=10.10.10.2 with continues ping and then go and shut down R2 (S1/0) I will see after a delay it will continue to ping:
R1#ping 10.10.10.2 repeat 10000000
Type escape sequence to abort.
Sending 10000000, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!………………………..!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
*Sep 13 18:10:14.419: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!.
R2#config t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#int s1/0
R2(config-if)#shut
R2(config-if)#
*Sep 13 18:07:27.595: %LINK-5-CHANGED: Interface Serial1/0, changed state to administratively down
R2(config-if)#
*Sep 13 18:07:27.595: %ENTITY_ALARM-6-INFO: ASSERT INFO Se1/0 Physical Port Administrative State Down
*Sep 13 18:07:28.595: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down
R2(config-if)#
Now lets look at show command on R2#
R2#show ppp multilink
Multilink200, bundle name is R1
Endpoint discriminator is R1
Bundle up for 00:25:03, total bandwidth 1544, load 1/255
Receive buffer limit 12000 bytes, frag timeout 1000 ms
0/0 fragments/bytes in reassembly list
29 lost fragments, 30 reordered
29/1847 discarded fragments/bytes, 0 lost received
0x2DC received sequence, 0x2A2 sent sequence
Member links: 1 active, 1 inactive (max not set, min not set)
Se1/1, since 00:24:37
Se1/0 (inactive)
No inactive multilink interfaces
As we see we have one active and one inactive, and BW has been dropped to 1544.
Lets give no shut on R2#
R2#config t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#int s1/0
R2(config-if)#no shut
Here is summary on R1 and R2:
R1#show run
interface Multilink100
ip address 10.10.10.1 255.255.255.252
ppp multilink
ppp multilink group 100
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
no ip address
encapsulation ppp
serial restart-delay 0
ppp multilink
ppp multilink group 100
!
interface Serial1/1
no ip address
encapsulation ppp
serial restart-delay 0
ppp multilink
ppp multilink group 100
Here is show run for R2#:
interface Multilink200
ip address 10.10.10.2 255.255.255.252
ppp multilink
ppp multilink group 200
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
no ip address
encapsulation ppp
serial restart-delay 0
ppp multilink
ppp multilink group 200
!
interface Serial1/1
no ip address
encapsulation ppp
serial restart-delay 0
ppp multilink
ppp multilink group 200
Receive our Cisco CCNA Packet Tracer!
Get our complete tutorial in PDF
[bs_icon name=”glyphicon glyphicon-expand”] Watch the video and you will be able to understand Cisco PPP Multilink Configuration much better and Please subscribe to our YouTube Channel.
Want more information on how to become Cisco CCNA Certified? Learn more!
Join our Cisco CCNA facebook study group!
Also published on Medium.