Cisco CCNA Video Training- DHCP Server

In this lab we are trying to make our Cisco Router Act as a DHCP server , that is R1 will give ip address 10.10.10.0/24 to left side Pc and it will give the IP address 20.20.20.0/24 to right side of PC. The Goal is Prepare you for your Cisco CCNA Certification exam.

DHCP goes thru these steps:
DORA

Step 1)   D= Discover packet

Step 2)   O= offer packet

Step 3)   R=Request packet

Step 4)   A=Acknowledge packe

Hint: When you configure the DHCP; your LAN must match with the ip address of your int f0/0  and Int f0/1.

R1#show ip int brief

Interface IP-Address OK?  Method  Status Protocol
FastEthernet0/0 10.10.10.100  YES manual  up up
FastEthernet0/1 20.20.20.100 YES manual  up up
Vlan1 unassigned YES unset administratively down down

 

Hint: Always start with ip DHCP?

Now I will go create a scope:

Step 1) define your Pool of address
R1#
R1#config t
R1(config)#ip dhcp ?
excluded-address  Prevent DHCP from assigning certain addresses
pool              Configure DHCP address pools

R1(config)#ip dhcp POOL ?

WORD  Pool name
R1(config)#ip dhcp POOL lan100
R1(dhcp-config)#?
default-router  Default routers
dns-server      Set name server
exit            Exit from DHCP pool configuration mode
network         Network number and mask
no              Negate a command or set its defaults
option          Raw DHCP options
R1(dhcp-config)#NETWork ?
A.B.C.D  Network number in dotted-decimal notation
R1(dhcp-config)#NETWork 10.10.10.0 ?
A.B.C.D  Network mask

R1(dhcp-config)#NETWork 10.10.10.0 255.255.255.0
R1(dhcp-config)#default-router ?

A.B.C.D  Router’s IP address
R1(dhcp-config)#default-router 10.10.10.100

Receive our Cisco CCNA Packet Tracer!
Get our complete tutorial in PDF

 

Here is my show run:
ip dhcp pool lan100
network 10.10.10.0 255.255.255.0
default-router 10.10.10.100

Step 2) lets exclude some address
R1#config t
Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#ip dhcp ?

excluded-address  Prevent DHCP from assigning certain addresses

pool              Configure DHCP address pools

R1(config)#ip dhcp exc

R1(config)#ip dhcp excluded-address ?

A.B.C.D  Low IP address

R1(config)#ip dhcp excluded-address 10.10.10.1 ?

A.B.C.D  High IP address

<cr>

R1(config)#ip dhcp excluded-address 10.10.10.1 10.10.10.20 ?

<cr>

R1(config)#ip dhcp excluded-address 10.10.10.1 10.10.10.20
Let’s see your show run
ip dhcp excluded-address 10.10.10.1 10.10.10.20

!

ip dhcp pool lan100
network 10.10.10.0 255.255.255.0
default-router 10.10.10.100

!
 
Now I will create a another scope for LAN 20.20.20.0/2:
R1#config t

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#ip dhcp ?

excluded-address  Prevent DHCP from assigning certain addresses

pool              Configure DHCP address pools

R1(config)#ip dhcp pool

R1(config)#ip dhcp pool ?

WORD  Pool name

R1(config)#ip dhcp pool lan200

R1(dhcp-config)#?

default-router  Default routers

dns-server      Set name server

exit            Exit from DHCP pool configuration mode

network         Network number and mask

no              Negate a command or set its defaults

option          Raw DHCP options

R1(dhcp-config)#netw

R1(dhcp-config)#network 20.20.20.0 ?

A.B.C.D  Network mask

R1(dhcp-config)#network 20.20.20.0 255.255.255.0

R1(dhcp-config)#de

R1(dhcp-config)#default-router 20.20.20.100

R1(dhcp-config)#
Here is my show run
ip dhcp excluded-address 10.10.10.1 10.10.10.20

!

ip dhcp pool lan100
network 10.10.10.0 255.255.255.0
default-router 10.10.10.100

ip dhcp pool lan200
network 20.20.20.0 255.255.255.0
default-router 20.20.20.100
Now I will give out 2nd exclusion:
R1#config t

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#ip dhcp ?

excluded-address  Prevent DHCP from assigning certain addresses

pool              Configure DHCP address pools

R1(config)#ip dhcp excluded-address ?

A.B.C.D  Low IP address

R1(config)#ip dhcp excluded-address 20.20.20.1 20.20.20.20 ?

<cr>

R1(config)#ip dhcp excluded-address 20.20.20.1 20.20.20.20
Here is my show run
ip dhcp excluded-address 10.10.10.1 10.10.10.20

ip dhcp excluded-address 20.20.20.1 20.20.20.20

!

ip dhcp pool lan100
network 10.10.10.0 255.255.255.0
default-router 10.10.10.100

ip dhcp pool lan200
network 20.20.20.0 255.255.255.0
default-router 20.20.20.100

!

interface FastEthernet0/0

ip address 10.10.10.100 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 20.20.20.100 255.255.255.0

duplex auto

speed auto

Now If  I go to my pc I will say obtain IP address ;and you will see IP address is given to each PC on left side and right side and we should be able to ping from left to right.

Step 1) define your Pool of address
R1#R1#config t
R1(config)#ip dhcp ?
excluded-address  Prevent DHCP from assigning certain addresses
pool              Configure DHCP address poolsR1(config)#ip dhcp POOL ?

WORD  Pool name
R1(config)#ip dhcp POOL lan100
R1(dhcp-config)#?
default-router  Default routers
dns-server      Set name server
exit            Exit from DHCP pool configuration mode
network         Network number and mask
no              Negate a command or set its defaults
option          Raw DHCP options
R1(dhcp-config)#NETWork ?
A.B.C.D  Network number in dotted-decimal notation
R1(dhcp-config)#NETWork 10.10.10.0 ?
A.B.C.D  Network mask

R1(dhcp-config)#NETWork 10.10.10.0 255.255.255.0
R1(dhcp-config)#default-router ?

A.B.C.D  Router’s IP address
R1(dhcp-config)#default-router 10.10.10.100
————————Here is my show run—————————
ip dhcp pool lan100
network 10.10.10.0 255.255.255.0
default-router 10.10.10.100
Step 2) lets exclude some address
R1#config t

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#ip dhcp ?

excluded-address  Prevent DHCP from assigning certain addresses

pool              Configure DHCP address pools

R1(config)#ip dhcp exc

R1(config)#ip dhcp excluded-address ?

A.B.C.D  Low IP address

R1(config)#ip dhcp excluded-address 10.10.10.1 ?

A.B.C.D  High IP address

<cr>

R1(config)#ip dhcp excluded-address 10.10.10.1 10.10.10.20 ?

<cr>

R1(config)#ip dhcp excluded-address 10.10.10.1 10.10.10.20
—————–Lets see your show run——-
ip dhcp excluded-address 10.10.10.1 10.10.10.20

!

ip dhcp pool lan100
network 10.10.10.0 255.255.255.0
default-router 10.10.10.100

!
——————–Now I will create a another scope for LAN 20.20.20.0/2——————–
R1#config t

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#ip dhcp ?

excluded-address  Prevent DHCP from assigning certain addresses

pool              Configure DHCP address pools

R1(config)#ip dhcp pool

R1(config)#ip dhcp pool ?

WORD  Pool name

R1(config)#ip dhcp pool lan200

R1(dhcp-config)#?

default-router  Default routers

dns-server      Set name server

exit            Exit from DHCP pool configuration mode

network         Network number and mask

no              Negate a command or set its defaults

option          Raw DHCP options

R1(dhcp-config)#netw

R1(dhcp-config)#network 20.20.20.0 ?

A.B.C.D  Network mask

R1(dhcp-config)#network 20.20.20.0 255.255.255.0

R1(dhcp-config)#de

R1(dhcp-config)#default-router 20.20.20.100

R1(dhcp-config)#
———————Here is my show run———————
ip dhcp excluded-address 10.10.10.1 10.10.10.20

!

ip dhcp pool lan100
network 10.10.10.0 255.255.255.0
default-router 10.10.10.100

ip dhcp pool lan200
network 20.20.20.0 255.255.255.0
default-router 20.20.20.100
———————-Now I will give out 2nd exclusion—-
R1#config t

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#ip dhcp ?

excluded-address  Prevent DHCP from assigning certain addresses

pool              Configure DHCP address pools

R1(config)#ip dhcp excluded-address ?

A.B.C.D  Low IP address

R1(config)#ip dhcp excluded-address 20.20.20.1 20.20.20.20 ?

<cr>

R1(config)#ip dhcp excluded-address 20.20.20.1 20.20.20.20
——————-Here is my show run——————
ip dhcp excluded-address 10.10.10.1 10.10.10.20

ip dhcp excluded-address 20.20.20.1 20.20.20.20

!

ip dhcp pool lan100
network 10.10.10.0 255.255.255.0
default-router 10.10.10.100

ip dhcp pool lan200
network 20.20.20.0 255.255.255.0
default-router 20.20.20.100

!

interface FastEthernet0/0

ip address 10.10.10.100 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 20.20.20.100 255.255.255.0

duplex auto

speed auto

========================================================================

Now If  I go to my pc I will say obtain IP address ;and you will see IP address is given to each PC on left side and right side and we should be able to ping from left to right.

========================================================================

 

[bs_icon name=”glyphicon glyphicon-expand”] Watch the video and you will be able to understand DHCP Server much better and Please subscribe to our YouTube Channel.

50-discount-on-self-study-online-class
Want more information on how to become Cisco CCNA Certified? Learn more!
Join our Cisco CCNA facebook study group!


Also published on Medium.

Exit mobile version