Cisco Basic Router configuration

Posted filed under Cisco CCNA.

Here are the configuration for Basic Router Configuration

 

When You Open a new router you will see

Router>   This is called user mode;

then you type en=enable to get to enable mode

Router#   This is called privilege mode

 

Hint: Always always always you must go to config t mode that will take you to Global configuration mode

Router#config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#

Now I will show you how you give a HostName and  IP address to the interface like F0/0 

Please subscribe to receive complete explanation!

Get our complete tutorial in PDF

Enter configuration commands, one per line.  End with CNTL/Z.Router(config)#hostname R1

R1(config)#int

R1(config)#interface f0/0

R1(config-if)#

 

as we see I am in Interface mode of F0/0 or my router

 

Now I will give an IP address

R1(config-if)#

R1(config-if)#

R1(config-if)#ip address ?

A.B.C.D  IP address

dhcp     IP Address negotiated via DHCP

R1(config-if)#ip address 10.10.10.100

% Incomplete command.

R1(config-if)#ip address 10.10.10.100 ?

A.B.C.D  IP subnet mask

R1(config-if)#ip address 10.10.10.100 255.255.255.0

R1(config-if)#

 

Let’s try to ping pc1 from this position

R1(config-if)#ping 10.10.10.1

^

% Invalid input detected at ‘^’ marker.

 

Any time you see above it means you are in wrong mode; so

Type exit to go back one mode

 

 

R1(config)#ping 10.10.10.1

^

% Invalid input detected at ‘^’ marker.

 

R1(config)#

 

As we see Ping does not work in this mode

Let’s go back one more ; so type exit

 

R1#ping 10.10.10.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:

…..

Success rate is 0 percent (0/5)

R1#

 

So I see the ping works only in user mode and privilege mode

R1>

R1#

Ping and show does not work in config mode or interface mode

 

As we see the ping works; but I get no response; why?

Since by default all interface are in shut down mode

 

 

Hint: You must always memorize this commands 

Here is before my change ( Up and Up)

 

 

R1#show ip int brief

Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.10.10.100 YES manual administratively down down
FastEthernet0/1 unassigned YES unset  administratively down down
Vlan1 unassigned YES unset  administratively down down

 

R1#

 

Now to solve the problem; I must go to interface mode and give no shut

R1(config)#int f0/0

R1(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#

 

Now let’s check show IP int brief after this

R1#show ip int brief

Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.10.10.100 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Vlan1 unassigned YES unset  administratively down down

 

R1#

 

as we see the life is good for LAN 10.10.10.0/24

But i need to go and fix the other side; that is i need to go

R1#config t

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#int f0/1

R1(config-if)#ip address 20.20.20.100

% Incomplete command.

R1(config-if)#ip address 20.20.20.100 ?

A.B.C.D  IP subnet mask

R1(config-if)#ip address 20.20.20.100 255.255.255.0

R1(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

R1(config-if)#-

 

Now i will check other side   by show ip int brief

R1#show ip int brief

Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.10.10.100 YES manual up up
FastEthernet0/1 20.20.20.100 YES manual up up
Vlan1 unassigned YES unset  administratively down down

 

 

Now I should be able ping from LAN 10.10.10.0/24 to LAN 20.20.20.4/24

Now I show you the use of ? with space and ? Without space

R1#cl

R1#cl

R1#cl?

clear  clock

R1#clo

R1#clock ?

set  Set the time and date

R1#clock set ?

hh:mm:ss  Current Time

R1#clock set 15:15:10 ?

<1-31>  Day of the month

MONTH   Month of the year

R1#clock set 15:15:10 1 ?

MONTH  Month of the year

R1#clock set 15:15:10 1 feburary ?

% Unrecognized command

R1#clock set 15:15:10 1 february ?

<1993-2035>  Year

R1#clock set 15:15:10 1 february 2011 ?

<cr>

R1#clock set 15:15:10 1 february 2011

R1#

? Without space will finish your word

? With space will tell you what next command is

\

Ctrl+ A it moves all the way to beginning

ctrl+E it moves all the way to the end

ctrl+z= END   it will take you back to the beginning

 

Any time you type on interface; it will overwrite it

R1#show ip int brief

Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 50.50.50.100 YES manual up up
FastEthernet0/1 20.20.20.100 YES manual up up
Vlan1 unassigned YES unset  administratively down down

 

 

 

As we see it overwrite it

Let’s put it back

R1#

R1#config t

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#int f0/0

R1(config-if)#ip add

R1(config-if)#ip address 10.10.10.100 255.255.255.0

R1(config-if)#

 

Now life is back to normal

R1#

R1#config t

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#int f0/0

R1(config-if)#ip add

R1(config-if)#ip address 10.10.10.100 255.255.255.0

R1(config-if)#

 

Here is a command that you must know

R1#show run

R1#show running-config

Building configuration…

 

Current configuration : 474 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname R1

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.10.10.100 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 20.20.20.100 255.255.255.0

duplex auto

speed auto

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

!

line con 0

line vty 0 4

login

!

end

 

To save your work on router

R1#copy run

R1#copy running-config st

R1#copy running-config startup-config

Destination filename [startup-config]?

Building configuration…

[OK]

R1#

 

Now I will talk about the banner

R1#config t

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#ban

R1(config)#banner ?

login  Set login banner

motd   Set Message of the Day banner

R1(config)#banner motd

R1(config)#banner motd ?

LINE  c banner-text c, where ‘c’ is a delimiting character

R1(config)#banner motd #Welcome to hame router#

R1(config)#

 

Lets check it ( Just Type Exit and then you will see the Banner)

 

Here is a good command that will stop looking for DNS

If I type for example CCNA ; it will waste my time

R1#ccna

Translating “ccna”…domain server (255.255.255.255)

 

To fix it do as follow

R1#config t

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#no ip domain-loo

R1(config)#no ip domain-lookup

R1(config)#^Z

R1#

%SYS-5-CONFIG_I: Configured from console by console

 

Now we see it did not waste my time when I type CCNA

R1#ccna

Translating “ccna”

% Unknown command or computer name, or unable to find computer address

 

Let’s check the state of the interfaces

R1#show ip interface brief

Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.10.10.100 YES manual up up
FastEthernet0/1 20.20.20.100 YES manual up up
Vlan1 unassigned YES unset  administratively down down

 

——————-So the 10.10.10.0 network is on interface  fa0/0 and 20.20.20.0 is on fa0/1

——————-Also both links are int the up up state, which means they are operational

——————-Now we take a look at the routing table

R1#sh ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGPD – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter areaN1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGPi – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area* – candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route
Gateway of last resort is not set

10.0.0.0/24 is subnetted, 1 subnets

C        10.10.10.0 is directly connected, FastEthernet0/0
20.0.0.0/24 is subnetted, 1 subnets
C        20.20.20.0 is directly connected, FastEthernet0/1

 

 

Watch the video and you will be able to understand Basic Router Configuration much better and Please subscribe to our YouTube Channel.

 


50-discount-on-self-study-online-class
Want more information on how to become Cisco CCNA Certified? Learn more!
Join our Cisco CCNA facebook study group!

 


Also published on Medium.

Comments are closed.