Now I will do small Lab:
R4=10.10.10.4
R10=10.10.10.10 connected via LAN link
Also I will have IPV6 as follow:
r4 f0/0=2001:4444::4/64
r10 f0/0=2001:4444::10/64
In here we have R4 and R10 with the following:
Here is R4#Show run:
interface FastEthernet0/0
ip address 10.10.10.4 255.255.255.0
duplex auto
speed auto
ipv6 address 2001:4444::4/64
Here is R10 with so many loopback address:
interface Loopback0
ip address 100.100.100.100 255.255.255.0
!
interface Loopback1
no ip address
ipv6 address FEC0:1000::1/128
!
interface Loopback2
no ip address
ipv6 address FEC0:1000::2/128
!
interface Loopback3
no ip address
ipv6 address FEC0:1000::3/128
!
interface Loopback4
no ip address
ipv6 address FEC0:1000::4/128
!
interface FastEthernet0/0
ip address 10.10.10.10 255.255.255.0
duplex auto
speed auto
ipv6 address 2001:4444::10/64
Right now when i go to R4#show ipv6 route i do not see the loopback from R10 why ?Since i need to run EIGRP ipv6
R4#show ipv6 route
IPv6 Routing Table – 3 entries
Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP
U – Per-user Static route, M – MIPv6
I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary
O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2
ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2
D – EIGRP, EX – EIGRP external
C 2001:4444::/64 [0/0]
via ::, FastEthernet0/0
L 2001:4444::4/128 [0/0]
via ::, FastEthernet0/0
L FF00::/8 [0/0]
via ::, Null0
So remember you need enable unicast-routing and also advertise under interface
Hint: On global Configuration start with IP6 ?
On interface configuration start with iPV6 ?
Here is my configuration:
R4#
R4#config t
Enter configuration commands, one per line. End with CNTL/Z.
R4(config)#ipv
R4(config)#ipv6 ?
access-list Configure access lists
cef Cisco Express Forwarding
dhcp Configure Ipv6 DHCP
general-prefix Configure a general IPv6 prefix
host Configure static hostnames
inspect Context-based Access Control Engine
local Specify local options
nat NAT-PT Configuration commands
neighbor Neighbor
route Configure static routes
router Enable an IPV6 routing process
unicast-routing Enable unicast routing
R4(config)#ipv6 router ?
eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)
ospf Open Shortest Path First (OSPF)
rip IPv6 Routing Information Protocol (RIPv6)
R4(config)#ipv6 router eig
R4(config)#ipv6 router eigrp ?
<1-65535> Autonomous system number
R4(config)#ipv6 router eigrp 100 ?
<cr>
R4(config)#ipv6 router eigrp 100
% IPv6 routing not enabled
R4(config)#ip
R4(config)#ipv
R4(config)#ipv6 un
R4(config)#ipv6 unicast-routing
R4(config)#
R4(config)#ipv6 router eigrp 100
R4(config-rtr)#
As we see i need to do unicast-routing
Now I go under the int f0/0 and do IPV6?
R4#config t
Enter configuration commands, one per line. End with CNTL/Z.
R4(config)#int f0/0
R4(config-if)#ipv
R4(config-if)#ipv6 ?
address Configure IPv6 address on interface
authentication authentication subcommands
dhcp IPv6 DHCP interface subcommands
eigrp Configure EIGRP IPv6 on interface
enable Enable IPv6 on interface
flow NetFlow Related commands
hello-interval Configures IP-EIGRP hello interval
inspect Apply inspect name
mtu Set IPv6 Maximum Transmission Unit
nat Enable IPv6 NAT on interface
nd IPv6 interface Neighbor Discovery subcommands
ospf OSPF interface commands
rip Configure RIP routing protocol
summary-address Summary prefix
traffic-filter Access control list for packets
R4(config-if)#ipv6 ei
R4(config-if)#ipv6 eigrp ?
<1-65535> AS number
R4(config-if)#ipv6 eigrp 100 ?
<cr>
R4(config-if)#ipv6 eigrp 100
R4(config-if)#
Here is my show run for R4:
R4#show run
ipv6 unicast-routing
interface FastEthernet0/0
ip address 10.10.10.4 255.255.255.0
duplex auto
speed auto
ipv6 address 2001:4444::4/64
ipv6 eigrp 100
ipv6 router eigrp 100
shutdown
Hint: as we see under the ipv6 router EIGRP 100, I need to give no shut
R4(config)#ipv6 router eigrp ?
<1-65535> Autonomous system number
R4(config)#ipv6 router eigrp 100
R4(config-rtr)#no shut
R4(config-rtr)#
Now I will do same concept on R10 — but make sure advertise it under all loopback .
R10(config)#ipv6 ?
access-list Configure access lists
cef Cisco Express Forwarding
dhcp Configure Ipv6 DHCP
general-prefix Configure a general IPv6 prefix
host Configure static hostnames
inspect Context-based Access Control Engine
local Specify local options
nat NAT-PT Configuration commands
neighbor Neighbor
route Configure static routes
router Enable an IPV6 routing process
unicast-routing Enable unicast routing
R10(config)#ipv6 un
R10(config)#ipv6 unicast-routing
R10(config)#ipv6 router ?
eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)
ospf Open Shortest Path First (OSPF)
rip IPv6 Routing Information Protocol (RIPv6)
R10(config)#ipv6 router ei
R10(config)#ipv6 router eigrp ?
<1-65535> Autonomous system number
R10(config)#ipv6 router eigrp 100 ?
<cr>
R10(config)#ipv6 router eigrp 100
R10(config-rtr)#no shut
R10(config-rtr)#
Here is my show run so far
R10#show run
ipv6 unicast-routing
ipv6 router eigrp 100
no shutdown
!
Now i will go under loopback 1,2,3,4 and advertise it
R10#config t
Enter configuration commands, one per line. End with CNTL/Z.
R10(config)#int lo 1
R10(config-if)#ipv
R10(config-if)#ipv6 ?
address Configure IPv6 address on interface
authentication authentication subcommands
dhcp IPv6 DHCP interface subcommands
eigrp Configure EIGRP IPv6 on interface
enable Enable IPv6 on interface
flow NetFlow Related commands
hello-interval Configures IP-EIGRP hello interval
inspect Apply inspect name
mtu Set IPv6 Maximum Transmission Unit
nat Enable IPv6 NAT on interface
nd IPv6 interface Neighbor Discovery subcommands
ospf OSPF interface commands
rip Configure RIP routing protocol
summary-address Summary prefix
traffic-filter Access control list for packets
R10(config-if)#ipv6 eig
R10(config-if)#ipv6 eigrp ?
<1-65535> AS number
R10(config-if)#ipv6 eigrp 100 ?
<cr>
R10(config-if)#ipv6 eigrp 100
R10(config-if)#
R10(config-if)#int lo 2
R10(config-if)#
R10(config-if)#ipv6 eigrp 100
R10(config-if)#
R10(config-if)#
R10(config-if)#int lo 3
R10(config-if)#
R10(config-if)#ipv6 eigrp 100
R10(config-if)#
R10(config-if)#
R10(config-if)#int lo 4
R10(config-if)#
R10(config-if)#ipv6 eigrp 100
R10(config-if)#
Here is my show run so far on R10:
ipv6 unicast-routing
!
!
interface Loopback1
no ip address
ipv6 address FEC0:1000::1/128
ipv6 eigrp 100
!
interface Loopback2
no ip address
ipv6 address FEC0:1000::2/128
ipv6 eigrp 100
!
interface Loopback3
no ip address
ipv6 address FEC0:1000::3/128
ipv6 eigrp 100
!
interface Loopback4
no ip address
ipv6 address FEC0:1000::4/128
ipv6 eigrp 100
!
interface FastEthernet0/0
ip address 10.10.10.10 255.255.255.0
duplex auto
speed auto
ipv6 address 2001:4444::10/64
!ipv6 router eigrp 100
no shutdown
Now i go to R4#show ipv6 route
IPv6 Routing Table – 3 entries
Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP
U – Per-user Static route, M – MIPv6
I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary
O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2
ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2
D – EIGRP, EX – EIGRP external
C 2001:4444::/64 [0/0]
via ::, FastEthernet0/0
L 2001:4444::4/128 [0/0]
via ::, FastEthernet0/0
L FF00::/8 [0/0]
via ::, Null0
R4#
As we see I do not see nothing ? why not ?
Let’s look my neighbors
R4#show ipv6 eigrp neighbors
IPv6-EIGRP neighbors for process 100
Now neighbors why? Since when i look at R10#show run ; i see I forgot to advertise under int f0/0
R10#show run
interface FastEthernet0/0
ip address 10.10.10.10 255.255.255.0
duplex auto
speed auto
ipv6 address 2001:4444::10/64
Here is my configuration on R10:
R10#config t
Enter configuration commands, one per line. End with CNTL/Z.
R10(config)#int f0/0
R10(config-if)#ipv
R10(config-if)#ipv6 ?
address Configure IPv6 address on interface
authentication authentication subcommands
dhcp IPv6 DHCP interface subcommands
eigrp Configure EIGRP IPv6 on interface
enable Enable IPv6 on interface
flow NetFlow Related commands
hello-interval Configures IP-EIGRP hello interval
inspect Apply inspect name
mtu Set IPv6 Maximum Transmission Unit
nat Enable IPv6 NAT on interface
nd IPv6 interface Neighbor Discovery subcommands
ospf OSPF interface commands
rip Configure RIP routing protocol
summary-address Summary prefix
traffic-filter Access control list for packets
R10(config-if)#ipv6 ei
R10(config-if)#ipv6 eigrp ?
<1-65535> AS number
R10(config-if)#ipv6 eigrp 100 ?
<cr>
R10(config-if)#ipv6 eigrp 100
R10(config-if)#
%DUAL-5-NBRCHANGE: IPv6-EIGRP 100: Neighbor FE80::209:7CFF:FE9E:A501 (FastEthernet0/0) is up: new adjacency
As we see as soon as I did advertise under F0/0 of R10 I see some activity since I am sending hello packets to R4 and r4 has already send hello packets to me
Let’s check the neighbors
R4#show ipv6 eigrp neighbors
IPv6-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 Link-local address: Fa0/0 13 00:02:17 40 1000 0 1
FE80::201:96FF:FE3D:E001
Now let’s check R4#show ipv6 route
R4#show ipv6 route
IPv6 Routing Table – 7 entries
Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP
U – Per-user Static route, M – MIPv6
I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary
O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2
ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2
D – EIGRP, EX – EIGRP external
C 2001:4444::/64 [0/0]
via ::, FastEthernet0/0
L 2001:4444::4/128 [0/0]
via ::, FastEthernet0/0
D FEC0:1000::1/128 [90/156160]
via FE80::201:96FF:FE3D:E001, FastEthernet0/0
D FEC0:1000::2/128 [90/156160]
via FE80::201:96FF:FE3D:E001, FastEthernet0/0
D FEC0:1000::3/128 [90/156160]
via FE80::201:96FF:FE3D:E001, FastEthernet0/0
D FEC0:1000::4/128 [90/156160]
via FE80::201:96FF:FE3D:E001, FastEthernet0/0
L FF00::/8 [0/0]
via ::, Null0
R4#ping FEC0:1000::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:1000::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms
R4#ping FEC0:1000::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:1000::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms
R4#ping FEC0:1000::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:1000::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms
R4#ping FEC0:1000::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:1000::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms
Now let’s look at another show commands
R4#show ip protocols
R4#show ipv6 protocols
R4#show ipv6 protocols
IPv6 Routing Protocol is “connected”
IPv6 Routing Protocol is “static”
IPv6 Routing Protocol is “eigrp 100 ”
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Interfaces:
FastEthernet0/0
Redistributing: eigrp 100
Maximum path: 16
Distance: internal 90 external 170
So summary
1) Make sure you enable ipv6-unicast routing
2) Make sure you do Global configuration with ipv6 ? (Give no shut)
3) Make sure advertise it under the interface with int f0/0 ipv6 ?
Receive our Cisco CCNA Packet Tracer!
Get our complete tutorial in PDF
[bs_icon name=”glyphicon glyphicon-expand”] Watch the video and you will be able to understand Cisco EIGRP IPV6 Configuration much better and Please subscribe to our YouTube Channel.
Want more information on how to become Cisco CCNA Certified? Learn more!
Join our Cisco CCNA facebook study group!
Also published on Medium.